剑客
关注科技互联网

升级cocoapods1.1.0版本遇到的坑

前言

先容我吐槽两句, 最近写Swfit3.0, 要用到一些框架, 然后就用cocoapods嘛, 结果说要cocoapods1.1.0版本才行, 而自己的是cocoapods1.0.1版本的, 所以就想着升级嘛, 结果就遇到2个坑, 一个就是切换gem源不成功, 一直还是官方源, 不能切换到ruby.china这个gem源上, 最后重新启动机器才成功, 这是什么道理不懂, 别问我为什么想到重启电脑(毕竟哥当过网管….????), 还有一个就是安装cocoapods的时候一直升级不到1.1.0版本, 安装了好几次都还是1.0.1版本的, 也是百度了半天没发现答案, 最后还是去stackoverflow这里才找到答案的, 看来以后找问题答案还是老老实实在这里找吧. 好了, 吐槽也差不多了, 下面就详细滴图文并茂滴讲讲安装cocoapods1.1.0的正确姿势????当然了在这之前应该会需要升级ruby什么的, 这个就自行百度哈, 百度上有的我就不写了.

先切换gem源

gem sources --remove https://rubygems.org/
gem source -a https://gems.ruby-china.org

查看是否切换成功

gem source -l

如果出现下图这样的就说明切换成功了, 如果还是官方的源, 请手动重启电脑尝试????

切换成功

接下来就可以开始升级了cocoapods了

sudo gem install -n /usr/local/bin cocoapods --pre

是的, 你没看错是这个命令, 然后终端会出现一大推东西, 别管他, 最后停下来是这样的就差不多了

安装成功

然后敲下

pod --version

出现

1.1.0.rc.2

恭喜你, 安装成功

剩下的就是设置pod仓库了

pod setup

经过漫长(网速好的会快很多)的等待出现

setup成功

至此, 已经升级到cocoapods1.1.0了, 可以愉快的把玩Swift3.0的一些三方库了????

分享到:更多 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址