剑客
关注科技互联网

需要class,interface或enum

引入github上的一个项目后在编译时收到了“需要class,interface或enum”这样的错误。就像下图:

需要class,interface或enum

图片是我随便找的,不过错误是一样的。

这样的错误通常是由编码问题导致的,只需要修改文件编码或项目编码就可以了,然而随之而来的另一个问题就是代码中的中文可能会丢失。后来找的解决方案是这样的,在pom中指定项目编码:

<properties>
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    </properties>

还有就是在编译时指定编码格式,具体怎么做也忘了,请自行百度或谷歌吧。

分享到:更多 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址